Incorrect price on instrument SPX500
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issues with position SPX500 price which is incorrect has been resolved.
We apologize for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Aug 07, 2020 - 07:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 06, 2020 - 23:53 UTC
Investigating
Please note that we currently have technical issues with position SPX500 price which is incorrect.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Aug 06, 2020 - 23:40 UTC
This incident affected: Trading (Automatic execution).