Some users may experience login issues to Wallet Application
Incident Report for eToro
Resolved
The issue resolved.
We apologize for the inconvenience
Posted 21 days ago. Jul 02, 2019 - 15:35 BST
Identified
We are experiencing temporary technical difficulties due to third-party issues.
Stay tuned for further updates. We apologize for the inconvenience.
Posted 21 days ago. Jul 02, 2019 - 15:06 BST
This incident affected: Wallet.