Login to etoro.com was alternately unavailable for 5 min
Incident Report for eToro
Resolved
During that the login to eToro worked alternately.
Issue has been resolved after 5 min.
Posted Mar 09, 2020 - 10:00 GMT