Closing positions may be unavailable for some customers
Incident Report for eToro
Resolved
Some users experienced an issue in which the SL or TP did not trigger as they should have.
We have closed the positions at the rate which the SL or TP should have triggered.
The issue is now resolved.
We apologize for the inconvenience.
Posted about 2 months ago. Oct 23, 2018 - 19:42 BST
Investigating
Some customers may currently experience difficulties with closing positions.
We are aware of the issue and are working on resolving it.
Posted about 2 months ago. Oct 23, 2018 - 16:29 BST
This incident affected: Trading (Manual Trading, Automatic Execution).