Deposit transactions via ACH is unavailable for US users
Incident Report for eToro
Resolved
The Issue has been resolved.
Posted Dec 10, 2019 - 19:20 UTC
Investigating
We have identified a technical malfunction that prevents US users from depositing via ACH. The issue is currently being investigated by relevant key members. Apologies for the inconvenience.
Posted Dec 10, 2019 - 14:47 UTC
This incident affected: Payments (More).