Login issues from Singapore
Incident Report for eToro
Resolved
The incident has been resolved.
Functionality has been fully restored.
We apologize for the inconvenience.
Posted 3 months ago. Feb 06, 2019 - 10:02 GMT
Investigating
Users from Singapore may experience login issue to eToro platform. Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted 3 months ago. Feb 05, 2019 - 19:58 GMT
This incident affected: Apps (Login).