Deposits via UnionPay and SEA (OnlineBanking) are unavailable.
Incident Report for eToro
Resolved
Deposits via UnionPay and SEA are now working properly.
We apologize for the inconvenience.
Posted 7 months ago. Jan 09, 2019 - 17:38 GMT
Identified
We are sorry, but due to a technical issue, we are temporarily unable to process deposits via UnionPay and SEA (OnlineBanking).
Please select a different deposit method or try again later.
Posted 7 months ago. Jan 09, 2019 - 13:39 GMT
This incident affected: Payments (More).