eToro Wallet Application is Under Maintenance
Incident Report for eToro
Resolved
The incident has been resolved.
We identified an issue with one of our third-party providers.
Wallet functionality has been fully restored.
We apologize for the inconvenience.
Posted 5 months ago. Dec 23, 2018 - 08:08 GMT
Investigating
eToro Wallet application is under maintenance due to technical issues.
Please stay tuned for further updates.
We apologize for the inconvenience.
Posted 5 months ago. Dec 23, 2018 - 07:21 GMT
This incident affected: Wallet.