eToro Wallet Application is Under Maintenance
Incident Report for eToro
Resolved
Wallet functionality has been fully restored.
We apologize for the inconvenience.
Posted 3 months ago. Dec 10, 2018 - 12:07 GMT
Monitoring
Our technical teams have deployed a fix.
The Wallet application is back to full functionality.
We will keep monitoring the issue.
We apologize for the inconvenience.
Posted 3 months ago. Dec 10, 2018 - 11:23 GMT
Investigating
eToro Wallet application is under maintenance due to a failed service deployment.
We have identified the problem and our technical teams are working on a fix.
Please stay tuned for further updates.
We apologize for the inconvenience.
Posted 3 months ago. Dec 10, 2018 - 11:07 GMT
This incident affected: Wallet.