Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 08, 2025 - 22:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 06, 2025 - 14:13 UTC
Scheduled
We are always looking for ways to improve your trading experience, and sometimes this requires shutting down some features for a short period of time for scheduled maintenance. Therefore, please be aware that the following services will be unavailable between 08/03/2025 (Saturday), 22:00 and 09/03/2025 (Sunday), 02:00 GMT.
Affected services: - Opening new support tickets. - Live chat with eToro Customer Service. - Club dashboard and club services related to user's benefits.
During this period, these services will be temporarily unavailable.
We apologize for any inconvenience and appreciate your understanding in this matter.
Sincerely, The eToro team
Posted Feb 27, 2025 - 09:15 UTC
This scheduled maintenance affected: eToro Platform (live chat, Open Customer Service ticket).