Possible latency for loading etoro app in mobile
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The latency for loading etoro app in mobile issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 19, 2020 - 07:22 UTC
Update
We are continuing to work on a fix for this issue. Some of the users may experience this.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 09, 2020 - 12:04 UTC
Identified
We have found the root cause for the issue and resolved it for Android.

We are continuing to work on a fix for iOS.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 05, 2020 - 06:22 UTC
This incident affected: Login & Registration (eToro Connect).