Wallet is currently unavailable
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The login to wallet issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 05, 2020 - 12:10 BST
Investigating
Please note that we currently have technical issues with one of eToro’s services.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 05, 2020 - 11:36 BST
This incident affected: Wallet.