We are experiencing some issues with trading transactions.
Incident Report for eToro
Resolved
The incident has been resolved.
We apologize for the inconvenience.
Posted 24 days ago. Sep 26, 2019 - 14:20 BST
Identified
The issue has been identified and a fix is being implemented.
Posted 24 days ago. Sep 26, 2019 - 12:35 BST
Investigating
We are experiencing temporary technical difficulties. Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted 24 days ago. Sep 26, 2019 - 11:29 BST
This incident affected: Trading (Manual Trading).