Partial disruption when uploading files
Incident Report for eToro
Resolved
This incident has been resolved.
Posted May 03, 2020 - 16:34 BST
Identified
We've found the root cause for the issue and working on to solve it. A fix for this issue will be deployed in the upcoming days. Apologise for the interruption.
Posted Apr 30, 2020 - 09:57 BST
Investigating
We are currently investigating this issue.
Posted Apr 27, 2020 - 19:05 BST
Monitoring
We're still having a partial disruption when upload files. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Apr 27, 2020 - 19:00 BST
This incident affected: KYC.