Wire transfer deposit is temporary unavailable for US clients
Incident Report for eToro
Resolved
Re-enabling wire transfer for US users.
We apologize for the inconvenience.
Posted Mar 24, 2020 - 15:39 GMT
Investigating
Online banking deposit is available.
We apologize for the inconvenience.
Posted Mar 22, 2020 - 20:08 GMT
This incident affected: Payments (Wire Transfer).