Only CFD option is available when trying to get into position in some stocks
Incident Report for eToro
Resolved
The issue has been resolved
Posted Dec 10, 2019 - 10:29 UTC
Investigating
Only CFD option is available when trying to get into position in some stocks
Posted Dec 10, 2019 - 08:48 UTC
This incident affected: Trading (Manual trading - Real).