Login is currently unavailable
Incident Report for eToro
Resolved
We are pleased to inform you that the problem that caused the eToro platform to be temporarily unavailable has been resolved. We will monitoring this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 10, 2020 - 10:39 BST
Monitoring
We've found the root cause for the issue and solved it. We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and resolved completely. We will provide more updates here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 09, 2020 - 15:21 BST
Update
We are continuing to investigate this issue.
Posted Jun 09, 2020 - 14:53 BST
Update
We are continuing to investigate this issue.
Posted Jun 09, 2020 - 14:44 BST
Investigating
We are experiencing a temporary issue with our login service. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Jun 09, 2020 - 14:40 BST
This incident affected: Trading (Manual trading - Real, Automatic execution, CopyTrading), Login & Registration (Login), and Wallet.