Partial issue for completion of account in Australia
Incident Report for eToro
Resolved
We are pleased to inform you that the incident has been resolved. We will monitor this issue for the next 24 hours to ensure it is addressed for all customers and completely resolved.
We appreciate your understanding and apologise for the inconvenience.


Sincerely,
The eToro Team
Posted Jun 19, 2020 - 09:12 BST
Identified
We have identified the reason for the issue and mitigated its influence.

We will update as soon as it is fully resolved.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 19, 2020 - 08:57 BST
Investigating
Please note that we currently have a partial issue in completion of account in Australia.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Jun 19, 2020 - 06:46 BST