Possible issues with changing setting in mobile
Incident Report for eToro
Resolved
This incident was resolved.
Posted May 01, 2020 - 11:35 BST
Identified
We're currently experiencing technical issues with our mobile service. Clients using mobile eToro platform may experience issues with changing setting configurations. It can used web platform instead. We're apologizing for the inconvenience and working to solve this issue.
Posted May 01, 2020 - 10:13 BST
This incident affected: KYC.