Open positions issue
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Sep 01, 2020 - 14:20 UTC
Monitoring
We have implemented a solution to resolve the issue, and will monitor it for the next 24 hours to make sure it is successfully resolved.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Sep 01, 2020 - 14:08 UTC
Investigating
Please note that we currently have technical issues with one of eToro’s services. There is an issue with open a position, closing a position is working well.
Our team is working hard to resolve the issue. We appreciate your understanding and apologise for the inconvenience. Sincerely, The eToro Team.
Posted Sep 01, 2020 - 13:55 UTC
This incident affected: Trading (Manual trading - Real).