News Feed is partially unavailable. Issue is identified
Incident Report for eToro
Resolved
This issue has been resolved.
Posted Mar 16, 2020 - 12:11 UTC
Identified
We are experiencing a temporary issue with our News Feeds. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Mar 16, 2020 - 11:29 UTC
This incident affected: eToro Platform (Feeds).