Login is partially unavailable from east Asia states
Incident Report for eToro
Resolved
The issue has been resolved.
We apologize for any inconvenience.
Posted Apr 01, 2020 - 15:53 BST
Investigating
We are experiencing temporary technical difficulties. Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted Mar 23, 2020 - 15:00 GMT
This incident affected: Login & Registration (Login).