User stats page is unavailable
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Mar 30, 2021 - 04:34 UTC
Update
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Mar 30, 2021 - 00:12 UTC
Investigating
Please note that we currently have technical issues with User Stats.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 30, 2021 - 00:09 UTC
This incident affected: Platform (Stats).