Watchlist is currently down
Incident Report for eToro
Resolved
The issue has been resolved.
Posted Mar 22, 2020 - 09:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2020 - 09:39 UTC
Investigating
We are experiencing a temporary issue with Watchlist. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted Mar 22, 2020 - 09:38 UTC
This incident affected: eToro Platform (Watchlist).