The issue affecting credit card deposits has now been resolved.
Customers can now enter their credit card details and complete deposits as expected.
We sincerely apologize for the inconvenience and appreciate your patience while our team worked to resolve the issue.
Thank you for your understanding.
Sincerely, The eToro Team
Posted Jul 07, 2026 - 14:13 UTC
Investigating
We are currently experiencing an issue affecting credit card deposits.
Some users may be unable to enter their credit card details when attempting to make a deposit, as expected. Our team is actively investigating the issue and working to restore full functionality as quickly as possible.
We understand how frustrating this may be, especially if you're trying to fund your account, and we apologize for any inconvenience this may cause. We'll continue to keep you updated on our progress here.
Sincerely, The eToro Team
Posted Jul 07, 2026 - 13:45 UTC
This incident affected: Payments (Credit cards, Deposit).