Popular Investor Program is not available to join
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Oct 05, 2021 - 17:22 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 05, 2021 - 16:24 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 05, 2021 - 15:21 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 05, 2021 - 13:59 UTC
Identified
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Oct 05, 2021 - 13:12 UTC
Investigating
Dear eToro Customers and Partners,

Currently the Popular Investor Program is not available to join on eToro platform.
We are currently working to resolve the issue.

Sincerely,
The eToro Team
Posted Oct 05, 2021 - 12:27 UTC