Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 09, 2025 - 07:00 UTC
Scheduled
Some features on the eToro platforms will be unavailable on February 9th, 2025 for up to 2 hours.
We are always looking for ways to improve your trading experience, and sometimes this requires shutting down some features for a short period of time for scheduled maintenance. Therefore, please be aware that on Sunday, 09/02/2025, the following services will be unavailable between 07:00 and 09:00 GMT.
Affected services: - Trading operations on the Virtual (Demo) account in eToro web and mobile platforms
During the maintenance period: - The trading actions will not be available on the Virtual account - Stop Loss and Take Profit will remain operational and trigger if they are reached, however the positions will be closed in the Virtual account after the completion of maintenance
During the maintenance period, you will not be able to do the following: - Access to Virtual account (Home, Portfolio, Discovery, Watchlist pages) - Open new Trade positions in a Virtual (Demo) account - Manage the existing Trade positions in a Virtual (Demo) account
We apologize for any inconvenience and appreciate your understanding in this matter.
Sincerely, The eToro team
Posted Jan 30, 2025 - 09:53 UTC
This scheduled maintenance affected: Trading (Manual trading - Virtual) and eToro Platform (Portfolio - Virtual).