3rd Party provider maintenance

Scheduled for Jun 3, 04:30 - 04:40 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 02, 2026 - 12:06 UTC

Scheduled

To consistently ensure that you have the latest features and capabilities at your fingertips, eToro performs periodic upgrades to our systems.

One of our third-party partners will undergo scheduled maintenance on 03 June 2026 from 05:30 AM to 05:40 AM (UK time).

During this window, eToro Money Card holders in the UK and Europe may experience a brief disruption to card services. In rare cases, card transactions may be unsuccessful. We recommend that you retry card transactions, or have another card with you during this timeframe.

We apologize for any inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jun 02, 2026 - 12:06 UTC
This scheduled maintenance affects: eToro Money (Cash Account, Debit Card).