Some customers might create eMoney accounts
Incident Report for eToro
Resolved
Dear eToro Money Customers,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Mar 09, 2023 - 16:25 UTC
Identified
The root cause of the issue has been identified and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 09, 2023 - 16:04 UTC
This incident affected: eToro Money (Cash Account).