Some customers may experience a degradation in trading actions
Incident Report for eToro
Resolved
Hello All
The issue is resolved and our system is back to normal operation.
We appreciate your understanding and apologize for the inconvenience.
Thank you
The eToro team
Posted Aug 30, 2022 - 14:10 UTC
Monitoring
Hello
Our system experienced a slight degradation in service with regards to trading actions
A fix has been applied and the system is back to normal operation standards.
We are monitoring the system to make sure it is back to full operation.
We appreciate your understanding and apologize for the inconvenience
Thank you
The eToro team
Posted Aug 30, 2022 - 14:00 UTC
This incident affected: Trading (Manual trading - Real).