Open positions issue
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Sep 04, 2020 - 13:56 UTC
Monitoring
We have implemented a solution to resolve the issue, and will monitor it for the next hours to make sure it is successfully resolved.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Sep 03, 2020 - 14:37 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 03, 2020 - 14:37 UTC
Update
We are continuing to work on a fix for this issue.
More updates will be provided here.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Sep 03, 2020 - 14:18 UTC
Identified
The root cause of the issue has been identified and our developers are working to fix it.
Costumers may experience issues with open positions.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Sep 03, 2020 - 13:54 UTC
Investigating
Please note that we currently have technical issues with one of eToro’s services.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Sep 03, 2020 - 13:37 UTC
This incident affected: Trading (Manual trading - Real).