Some users from Vietnam may experience login issues
Incident Report for eToro
Resolved
The incident has been resolved.
We apologize for the inconvenience.
Posted Jun 19, 2019 - 16:52 UTC
Identified
Login may be unavailable for some users from Vietnam due to 3rd party network issues
Posted Jun 19, 2019 - 10:26 UTC
This incident affected: Login & Registration (Login).