Login is partially unavailable
Incident Report for eToro
Resolved
This incident has been resolved.
Posted May 18, 2020 - 15:14 BST
Identified
We've found the root cause for the issue and working to solve it. Apologize for the interruption
Posted May 18, 2020 - 14:27 BST
Monitoring
We are experiencing a partial issue with our login service. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted May 18, 2020 - 14:15 BST
This incident affected: Apps (Login).