Account Statement temporarily unavailable
Incident Report for eToro
Resolved
The Account Statement report is now working properly.
We apologize for the inconvenience.
Posted 21 days ago. Apr 03, 2019 - 17:18 BST
Investigating
The Account Statement report is not available at this time due to technical issues.
Please try again at a later time.
We apologize for the inconvenience and appreciate your understanding in this matter.
Posted 22 days ago. Apr 03, 2019 - 13:23 BST