Completed
The scheduled maintenance has been completed.
Posted Apr 26, 2026 - 07:45 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 26, 2026 - 07:41 UTC
Scheduled
Maintenance is still in progress and is now expected to be completed by 07:45 UTC.
Impact:
- Login to web and mobile platforms is unavailable
- Trading operations unavailable
- News Feed, Popular Investor feed, personal feeds, and instrument feed unavailable
- Stop Loss / Take Profit orders will not be triggered
You may use BackTrader (https://offlinemode.etoro.com/) to close open positions during this time.
We apologize for the inconvenience and appreciate your patience.
Posted Apr 26, 2026 - 07:40 UTC
This scheduled maintenance affected: Login & Registration (Login, Email verification, Registration, eToro Connect, SMS verification (2FA), Social Media, KYC), Payments (Credit cards, PayPal, Wire transfer, More, Withdrawal, Deposit), Trading (Manual trading - Real, Manual trading - Virtual, Automatic execution, CopyTrading), eToro Money (Cash Account, Debit Card, Crypto Wallets, Fast Transfer (Online Banking)), eToro Platform (Watchlist, Portfolio - Real, Portfolio - Virtual, Portfolio - History, Feeds, Discovery, Daily Gain, Charts, Notifications, Account verification, Popular Investors Dashboard, eToro Club Dashboard, Rates, Stop Loss, Take Profit, Tax identification, W8BEN, Interest on balance, live chat, Customer Help portal, Open Customer Service ticket), and Website, Affiliates portal, Search, Fees, Blockchain Network, Candles.