Login to eToro platform from some countries may be unavailable
Incident Report for eToro
Resolved
The incident has been resolved.
We apologize for the inconvenience.
Posted 3 months ago. Jul 18, 2019 - 10:48 BST
Monitoring
Login is now available, we will keep monitoring the status.
If you are still experiencing issues, please try to close and reopen the application/browser before retrying.
Posted 3 months ago. Jul 18, 2019 - 09:03 BST
Investigating
We are experiencing temporary technical difficulties.
Impacted countries:
United Arab Emirates
Oman
Philippines
Singapore
India
Indonesia
Malaysia
Cambodia
Kuwait

Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted 3 months ago. Jul 18, 2019 - 07:41 BST
This incident affected: Website.