Deposits via PayPal are temporary unavailable
Incident Report for eToro
Resolved
Deposits via PayPal are now working properly.
We apologize for the inconvenience.
Posted 7 months ago. Feb 04, 2019 - 16:10 GMT
Update
We are continuing to investigate this issue.
Posted 7 months ago. Feb 04, 2019 - 14:41 GMT
Investigating
We are experiencing a temporary issue with deposits via PayPal. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted 7 months ago. Feb 04, 2019 - 14:24 GMT
This incident affected: Payments (PayPal).