User stats page is currently unavailable
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Oct 14, 2020 - 08:54 UTC
Identified
We are experiencing a temporary issue with the stats.
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted Oct 14, 2020 - 08:16 UTC
This incident affected: eToro Platform (Daily Gain).