Users from UK may experience login issues
Incident Report for eToro
Resolved
The incident has been resolved.
Functionality has been fully restored.
We apologize for the inconvenience.
Posted 5 months ago. May 20, 2019 - 05:00 BST
Investigating
Users from the UK may experience login issue to eToro platform. Please bear with us while we work on resolving the issue and stay tuned for further updates. We apologize for the inconvenience.
Posted 5 months ago. May 20, 2019 - 03:22 BST
This incident affected: Apps (Login) and Website.