Some customers might experience problems on eToro platform
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 02, 2022 - 20:08 UTC
Update
We have implemented a solution to resolve the issue, and will monitor it for the next hours to make sure it is successfully resolved.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 02, 2022 - 18:02 UTC
Monitoring
We have implemented a solution to resolve the issue, and will monitor it for the next hours to make sure it is successfully resolved.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 02, 2022 - 14:27 UTC
Investigating
Please note that we currently have technical issues with some of eToro’s services.
Users might experience log in issues, trading issues or won't be able to see their portfolio.
Also eToro Money application is under maintenance.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Jan 02, 2022 - 13:39 UTC
This incident affected: Login & Registration (Login), Trading (Manual trading - Real), eToro Money (Crypto Wallets), and eToro Platform (Portfolio - Real).