Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 28, 2023 - 08:45 UTC
Scheduled
To consistently ensure that you have the latest features and capabilities at your fingertips, both eToro and our third party partners perform periodic upgrades to our system.
👉When will the upcoming maintenance take place?
One of our 3rd party partners will undergo maintenance on Sunday, May 28, 2023 from 08:45 am until 11:00 am GMT.
👉 Which services will be affected?
For users who hold $ADA in their eToro Money crypto wallet, the Send function will not be available during this maintenance window mentioned above.
🔊 We apologise for any inconvenience and appreciate your understanding in this matter, as always.
Posted May 24, 2023 - 13:40 UTC
This scheduled maintenance affected: eToro Money (Crypto Wallets).