New Australian clients may experience an issue to deposit funds
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We apologise for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Jul 03, 2020 - 13:21 BST
Identified
The root cause of the issue has been identified and our developers are working to fix it.
Additional information will be provided as soon as possible.
We appreciate your understanding and apologise for the inconvenience.

Sincerely,
The eToro Team
Posted Jul 03, 2020 - 12:52 BST
Investigating
We are experiencing a temporary issue with our deposit service for Australian clients.
We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Jul 03, 2020 - 12:52 BST
This incident affected: Payments (Deposit).