Partial disruption with withdrawals
Incident Report for eToro
Resolved
Issue has been resolved.
Posted Apr 27, 2020 - 13:52 BST
Investigating
We're currently having a partial disruption when opening withdraw Request - some of the users may experience failure to submit a withdrawal request. We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible
Posted Apr 27, 2020 - 12:03 BST
This incident affected: Payments (Withdrawals).