Degraded performance incident - Investigating
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The incident has been resolved.
We apologize for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Dec 14, 2022 - 08:57 UTC
Update
Hello,
Please note that we are currently experiencing technical issues with one of eToro’s services.
Our engineering team is working hard to resolve the issue.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Dec 14, 2022 - 08:19 UTC
Investigating
Hello,
Please note that we are currently experiencing technical issues with one of eToro’s services.
Our engineering team is working hard to resolve the issue.
We appreciate your understanding and apologize for the inconvenience.

Sincerely,
The eToro Team
Posted Dec 14, 2022 - 08:12 UTC
This incident affected: eToro Platform (Feeds).