Trading is currently unavailable for users across Europe
Incident Report for eToro
Resolved
This incident has been resolved.
Posted Dec 09, 2019 - 20:17 UTC
Update
The issue has been resolved
Posted Dec 09, 2019 - 13:22 UTC
Investigating
We have identified users that are encountering issues when attemtping to fill in the ESMA questionnaire. Therefore, trading will not be applicable and the issue is being investigated by relevant key members.
Posted Dec 09, 2019 - 13:04 UTC
This incident affected: Trading (Manual trading - Real).