eToro Wallet Application is Under Maintenance
Incident Report for eToro
Resolved
The incident has been resolved.
Wallet functionality has been fully restored.
We apologize for the inconvenience.
Posted 5 months ago. Feb 28, 2019 - 22:48 GMT
Investigating
eToro Wallet application is under maintenance due to technical issues.
Please stay tuned for further updates.
We apologize for the inconvenience.
Posted 5 months ago. Feb 28, 2019 - 22:28 GMT
This incident affected: Wallet.