Feeds on eToro homepage are not available
Incident Report for eToro
Resolved
Dear eToro Customers and Partners,
The issue has been resolved.
We appreciate your understanding and apologies for the inconvenience.


Sincerely,
The eToro Team
Posted Mar 01, 2022 - 15:13 UTC
Investigating
Please note that we currently have technical issues with one of eToro’s services.
Our team is working hard to resolve the issue.
We appreciate your understanding and apologies for the inconvenience.

Sincerely,
The eToro Team
Posted Mar 01, 2022 - 14:40 UTC
This incident affected: eToro Platform (Feeds).