The markets may be displayed as closed

Incident Report for eToro

Resolved

Dear eToro Customers and Partners,

The incident has been resolved.

We apologize for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Mar 30, 2026 - 11:21 UTC

Investigating

We are currently investigating an issue where the markets may be displayed as closed. As the markets are closed trades cannot be placed in instruments. You can manage your open trades at this link: https://offlinemode-new.etoro.com/login

Our team is actively investigating and working to restore full functionality as soon as possible.

We apologize for the inconvenience and appreciate your patience. Updates will be shared here as they become available.

Sincerely,
The eToro team
Posted Mar 30, 2026 - 10:41 UTC
This incident affected: Trading (Manual trading - Real, Manual trading - Virtual, Automatic execution).