Temporary Platform Latency Affecting Order Execution

Incident Report for eToro

Resolved

Dear eToro Customers and Partners,

The incident has been resolved.

We apologize for the inconvenience and appreciate your understanding in this matter.

Sincerely,
The eToro Team
Posted Feb 18, 2025 - 15:37 UTC

Investigating

We are experiencing a temporary issue with latency on the platform which may impact some order execution.

We apologize for the inconvenience and appreciate your patience as we work on resolving it as quickly as possible.
Posted Feb 18, 2025 - 15:14 UTC
This incident affected: Trading (Manual trading - Real) and eToro Platform (Watchlist, Portfolio - Real).