Deposit via ACH is unavailable
Incident Report for eToro
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 03, 2019 - 09:07 BST
Investigating
Deposit via ACH is currently unavailable.
Our engineers are investigating the issue.
We apologize for the inconvenience and appreciate your patience as we work on resolving the issue.
Posted 3 months ago. Aug 02, 2019 - 22:42 BST
This incident affected: Payments (More).